[Résolu]Performance...
#1
Bonjour,

J'avais remarqué que le forum etait de plus en plus lent à réagir (parfois plusieurs minutes pour afficher une seule page !). Hier soir, il était tout simplement impossible d'utiliser le forum, le serveur qui nous hébérge est visiblement sur le point de s'écrouler.

Je voulai simplement savoir si ces difficultés sont temporaires et si quelque chose est prévu pour améliorer les choses... Vu la faible frequentation de ce forum (tout est relatif mais bon...), je me doute bien que le serveur doit hébérger pas mal d'autres trucs... est ce que l'on sait quoi ? Bref, qui gere l'hebergement ?

Je voulai aussi signaler que si la situation se dégradait vraiment, j'ai un (enfin deux) serveurs linux qui tournent 24h/24. Bien sur il ne s'agit pas d'un hébergement pro, juste de ma connexion personel (adsl avec 1Mb/s en upload). J'heberge d'ailleur déjà un forum... Meme si ce n'est surement pas aussi fiable qu'une solution "pro" j'intervient rapidemeent en cas de problème, et jamais par exemple on aurait pu perdre une base de donnée (je suis un maniaque des sauvegarde, et j'ai le matos qu'il faut pour cela Wink

Voila, j'espere juste que les performances s'amelioreront parce que ces jours ci c'était vraiment pénible quand meme...
Répondre
#2
PS : Aujourd'hui ca tout semble redevenu normal, pourvu que ca dure Smile
Répondre
#3
C'est Salla qui s'occupe du côté technique, mais il est actuellement assez pris et n'a apparemment pas trop le temps de se connecter.

En tout cas, MERCI infiniment de proposer une solution et de ne pas te contenter de geindre « bouh, le forum rame », une ritournelle qui me revient souvent aux oreilles et qui me lasse sérieusement. Je te conseille d'essayer d'entrer en contact avec Salla pour que vous puissiez en discuter.
"Hey it's me, I'm dynamite and I don't know why"
Répondre
#4
Si jamais les problèmes revenaient de facon vraiment importante, j'essayerai.
Pour le moment ca roule Smile ca faisait meme longtemps que crois que ca n'avais pas marché aussi bien...
Répondre
#5
Ouaip je crois que Oiseau fait des expériences de distorsion du temps pour aller pécher ses idées dans les mondes paralléles. Mrgreen
Répondre
#6
Bon la dernière trouvaille sur RameV1.com, quand on poste un message, il n'apparait pas (mais le lien si !). Il apparait quelques temps après (durée indéterminée mais supérieure à 5 min)
— Je suis la nouvelle impératrice ! Et toi tu vas mourir.
Lempi Chukwumoguey
Répondre
#7
Salut, me voila de retour, suite a mon demenagement de Paris pour Grenoble. Apres un mois d'attente free vient enfin de me donner une freebox, donc i am back Cool

Alana a écrit :Bonjour,

J'avais remarqué que le forum etait de plus en plus lent à réagir (parfois plusieurs minutes pour afficher une seule page !). Hier soir, il était tout simplement impossible d'utiliser le forum, le serveur qui nous hébérge est visiblement sur le point de s'écrouler.

Je voulai simplement savoir si ces difficultés sont temporaires et si quelque chose est prévu pour améliorer les choses... Vu la faible frequentation de ce forum (tout est relatif mais bon...), je me doute bien que le serveur doit hébérger pas mal d'autres trucs... est ce que l'on sait quoi ? Bref, qui gere l'hebergement ?

Je voulai aussi signaler que si la situation se dégradait vraiment, j'ai un (enfin deux) serveurs linux qui tournent 24h/24. Bien sur il ne s'agit pas d'un hébergement pro, juste de ma connexion personel (adsl avec 1Mb/s en upload). J'heberge d'ailleur déjà un forum... Meme si ce n'est surement pas aussi fiable qu'une solution "pro" j'intervient rapidemeent en cas de problème, et jamais par exemple on aurait pu perdre une base de donnée (je suis un maniaque des sauvegarde, et j'ai le matos qu'il faut pour cela Wink

Voila, j'espere juste que les performances s'amelioreront parce que ces jours ci c'était vraiment pénible quand meme...
Pour ce qui est de l'hébergement actuel, il s'agit d'un serveur Debian avec 2 Mb/s en uplaod, mais seulement 64 Mo de Ram. Ce serveur héberge aussi le wiki sur Titan, et les scripts Dokuwiki et mybb sont tous deux tres lourds, et quand les deux sont fortement solicité a la fois, ca ram, voir plante (ce n'est pas du tout un problème de bande passante). Sinon, il y a des sauvegardes périodiques hebdomadaire le samedi. Ta proposition Alana est en effet intéressante, si tu penses qu'elle résoudra les problèmes de ram. Si tu es toujours partant, on peut essayer un migration à l'essaie du forum. Pour cela, tu peux installer le forum mybb, et je t'enverais un dump de la bd.
En tout cas merci beaucoup de proposer une solution.
Répondre
#8
Bonjour,

64 Mo ! A oui... effectivement... Je pense que l'application serait plus à l'aise ici...
A condition que la bande passante en upload ne soit pas un problème (surtout que l'unique Mb dont je dispose est parfois en parti occupé à autre chose...)
Mais je pense que ca mériterai qu'on fasse l'essai. Je vais donc essayer d'installer mybb (il faut aussi que je me renseigne un peu sur ce truc, pour vérifier qu'il pose pas trop de problèmes niveau sécurité).
Sinon c'est quoi comme type de ram exactement dans ta machine ? il te reste des slots dispo ?
Tu pense que ce n'est qu'un probleme de ram, ou le cpu aussi est juste ?

EDIT : mybb est installé. Il y a une adresse mail ou je peux te joindre ?
Répondre
#9
Le serveur est en fait un serveur virtuel qui tourne sur un gros serveur de 4Go de ram. Les 64 Mo sont le minimum garantie de ma subdivision. Pour le cpu, je n'ai pas observé de grosse consommation par les applications web. Pour le reste FlèchePM Wink
Répondre
#10
Voilà, le forum a changé de serveur. L'url a changé, mais l'ancienne redirigera toujours vers ici. Si dans les jours qui viennent vous observez des ralentissement des bug etc, n'hésitez pas à le signaler. Vous pouvez aussi tester les boites de messagerie, ou modifier vos profils, il arrive assez souvent que des bugs apparaissent dans ces coins là lors des grandes opérations sur le forum.

Sinon, j'ai enfin résolue le problème de caractère accentué en convertissant la base en UTF8, donc vous pouvez utiliser à nouveau la fonction d'édition rapide.

Et encore merci à toi Alana!

Edit (rapide lol) : si Oiseau et Meneldur passe par là, ils peuvent supprimer le messages d'entête de page invitant à ne pas utiliser la fonction d'édition rapide.
Répondre
#11
Bravo Salla !

J'ai vraiment essayé un moment hier de résoudre cette histoire de codage de caractères, mais rien à faire.
Au final, j'ai préféré le laisser faire et je vois que j'ai bien fait Smile
Il faudra vraiment que tu m'envoi un petit mail pour me dire exactement comment tu as fait...

Sinon j'avais choisi cette url un peu au pif, pensant que nous pourrions garder l'ancienne de toute maniere, ce qui ne semble pas pouvoir etre le cas.
Du coup, si vous voulez une autre url, ca ne pose pas aucun problèmes...
J'utilise le site dyndns.org qui propose de choisir dans une liste de nom de domaine possible.
On peut aussi supprimer le /forum si vous voulez... (a vous de voir si potentiellement un jour il pourrait y avoir un site ou pas).
Voila quelques propositions :

rdv1.does-it.net
rdv1.better-than.tv
rdv1.fore-more.biz
rdv1.for-our.info
rdv1.simple-url.com
rdv1.gotdns.com
rdv1.homedns.com
rdv1.selfip.com

Ce ne sont que quelques exemples... et parfois on peut aussi choisir entre .com et .org.
Bon maintenant puisque tout fonctionne comme ca on peut aussi se moquer éperdument de l'url et garder celle la...
c'est vous qui voyez Smile

EDIT : Que ce soit moi ou Salla, on est tres mal placé pour savoir si il y a une grosse différence de performances...
(pour moi maintenant c'est instantané, mais vu que je suis en local....) Bref, faites nous des retours, dite nous si
ca vaut le coup de rester comme ca Smile Si la réponse est oui, je vais scripter des sauvegardes journalières de la base...
Répondre
#12
Merci beaucoup Salla!
Un seul truc, les icones indiquants les nouveaux messages étaient plus classes avant.

EDIT: pour la performance, le forum marche beaucoup plus vite chez moi!
Debout, debout cavaliers de Théoden!
Les lances seront secouées, les boucliers voleront en éclat,
Une journée de l'épée, une journée rouge avant que le soleil ne se lève !
Au galop ! au galop ! courez ! Courez à la ruine et à la fin du monde !
Répondre
#13
La performance paraît s'être améliorée de mon côté également. Je suppose qu'il est encore trop tôt pour en juger définitivement.
Répondre
#14
Aragorn : quel theme utilises tu le vert ou le bleu, si c'est le bleu, c'est normal, j'ai préférer laisser les icones de base pour le theme original de postgres.

Sinon pour ma part j'ai un probleme pour me déloguer, suis je le seul ?
Répondre
#15
Tiens... tres bizarre... moi non plus je ne peux pas me déconnecter.
Répondre




Utilisateur(s) parcourant ce sujet : 1 visiteur(s)